SVERWEIS mit genauer Suche

Beispiel: SVERWEIS-Übung2

Preistabelle, der Preis des Artikels soll mit der Funktion SVERWEIS ermittelt werden.
Preistabelle, der Preis des Artikels soll mit der Funktion SVERWEIS ermittelt werden.

In diesem Beispiel soll in Zelle B4 die Einheit und der Preis des Artikels in Zelle B2 mit der SVERWEIS-Funktion ermittelt werden. Zuvor bekommt die Zelle B2 eine Dropdownliste zur Auswahl des Artikels. Markieren Sie B2 und wählen Sie im Register Daten/Datenüberprüfung.

Auswahl der Datenüberprüfung in Excel, um einer Zelle eine Dropdown-Liste zuzuweisen
Gültigkeitsprüfung in Excel, Datenüberprüfung

Wählen Sie im Feld „Zulassen“ den Wert „Liste“. Der Bereich E2:E10 wird als Quelle für die Dropdownliste zugewiesen. Dazu können Sie den Bereich einfach mit der Maus markieren. Nach der Bestätigung mit OK erhalten Sie dann in der Zelle B2 eine Dropdownliste.

Zelle mit Dropdownliste

Einheit ermitteln:

=SVERWEIS(B2;E2:G10;2;0)
Der Name des Artikels in Zelle B2 ist das Suchkriterium. Der Bereich von E2 bis G10 stellt die Suchmatrix dar. Der gesuchte Wert befindet sich in Spalte 2 der Matrix, deshalb heißt unser Spaltenindex 2.

Das letzte Argument „Bereich-Verweis“ muss den Wert 0 haben, damit der richtige Artikel gefunden wird. 0 bedeutet hier, dass genau der Wert gefunden werden muss, der dem Suchkriterium entspricht.

Preis ermitteln:

Ein Bild, das Screenshot, Wand enthält.

Automatisch generierte Beschreibung

=SVERWEIS(B2;E2:G10;3;0)         
Der Name des Artikels in Zelle B2 ist das Suchkriterium. Der Bereich von E2 bis G10 stellt die Suchmatrix dar. Der gesuchte Wert befindet sich in Spalte 3 der Matrix, deshalb heißt unser Spaltenindex 3.

Das Argument „Bereich-Verweis“ muss den Wert 0 haben, damit der richtige Artikel gefunden wird. Wenn diese Angabe 0 fehlt oder eine 1 angegeben wird, versucht Excel, den gesuchten Wert in einen Bereich einzuordnen. Dann funktioniert es nur, wenn die Spalte E alphabetisch sortiert ist, sonst wird ein falsches Ergebnis ermittelt.

Beispieldatei downloaden

Schreiben Sie einen Kommentar

Ihre E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.